Announcement

Collapse
No announcement yet.

Xsc idle/run issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Xsc idle/run issue

    Hey my fathers xsc is havin some problems,it won't keep a steady idle it idles up and down and it only run for about 10 minutes aslong as you keep giving it throttle them it dies....any ideas?

  • #2
    Possible air leak.Vent the tank.

    Comment


    • #3
      Those were the first things I checked,sprayed dw40 around carb and intake and no change tested my tank (mines vented) no change,I thought maybe his needles were set wrong but I went rich on low speed and worked back and it just wants to die if I don't keep giving it gas.

      Comment


      • #4
        Do you have the carb set?
        Also check to see if the throttle servo is causing the rpm fluctuations.
        Sometimes the stock carbs can be problematic. It might be time to upgrade.

        Comment


        • #5
          It's a Hitec 645 throttle servo no movement in it,I tryed setting the carb but doesn't seem to work,only way it will stay running is if its revving high an the truck is jerking forward

          Comment


          • #6
            The actual idle screw should that be turned all the way in for tuning? I've always wondered that....my mt I just set by low speed needle and a little idle screw and the runs good now but curious about the idle screw

            Comment


            • #7
              The idle should be set per your preference. I like mi e idled a touch on the high side.

              Comment


              • #8
                If the idle is all the way in...Is the low needle is set?

                The leaner it gets the higher the idle rpm...then you can back out the idle a little.

                Comment


                • #9
                  I think I got it....he was runnin the redcat "performance" mt pipe and that had a massive air leak so I put the stock can from my mt on and it runs perfect!

                  Comment


                  • #10
                    Ok so...I fixed the idle problem however it still dies,it will sit there and idle no problem but as soon as you give it gas and let off it dies,I've even tryed a different motor with the same carb and same issue so possible the carb is no good?

                    Comment

                    Working...
                    X